DrupalのQuickEdit機能の権限チェックに脆弱性。Webサイトへの影響と対策について (CVE-2022-25270)

こんにちは。「SiteCloud」プリセールスの高瀬です。

2022年2月にDrupalにクイック編集機能に脆弱性(CVE-2022-25270)が発表されました。

悪用されるとログインユーザーが閲覧権限のないコンテンツを参照できる可能性があり、アメリカ国立標準技術研究所の脆弱性データベースでは危険度がMediumとなっています。

https://nvd.nist.gov/vuln/detail/CVE-2022-25270

QuickEditモジュールを使っているサイトでインプレース編集へのアクセス権限を持ったユーザーが本来閲覧できないコンテンツを参照できる可能性があります。

脆弱性の対象となるバージョン

影響を受けるバージョンは下記の通りです。

・Drupal 9.3.6 未満

・Drupal 9.2.13 未満

脆弱性の対策

既に修正済みバージョンが提供されているため、検証の上、Drupal本体をバージョンアップする形になります。

https://www.drupal.org/sa-core-2022-004

Webサイトへの影響について

DrupalのQuickEditモジュールをインストールしていて、インプレース編集へのアクセス権限を管理者以外のユーザーに設定している場合に閲覧権限のないコンテンツを参照できる可能性があります。

通常はコンテンツの編集権限があるユーザーのため、社内で管理しているサイトの場合は問題ありませんが、不特定多数のユーザーが投稿できるようになっているサイトでは権限の設定を確認する必要があります。

さいごに

DrupalはオープンソースCMSの中でも高機能と言われており、さまざまなモジュールが用意されています。

CMSのカスタマイズ性が高い一方で、各機能のセキュリティ対策には注意が必要です。

弊社ではお客様サーバーのご利用状況に応じて、エンジニアが日々発表される脆弱性の影響有無を確認して、必要に応じて修正パッケージの適用を行なっております。

サイト制作、運用が多忙でサーバーソフトの脆弱性対策を行うことが難しい場合はぜひご相談くださいませ。

コーポレートサイトをクラウドでセキュアに

SiteCloudガイドブック

「SiteCloud」の詳しい内容が分かる資料をご用意しました。
  • コーポレートサイト構築・運用の課題を解決
  • SiteCloudの主な機能
  • 導入事例
  • 導入までの流れ

関連する解決策

最新記事

タグ

詳しい資料をご覧いただけます

    サイバーの鎧のサービス内容を記載した資料をダウンロードできます。
             

【無料診断実施中】サーバーセキュリティ診断

経験豊富なセキュリティ専門技術者が、サーバーの状況を診断して、分かりやすい診断結果と今後の対応策をご覧いただけます。

無料サーバー診断申し込み
close