プロフィール作成プラグイン「The Profile Builder」にXSS脆弱性。WordPressで動作しているブログサイトへの影響と対策について (CVE-2022-0653)

こんにちは。「SiteCloud」プリセールスの高瀬です。

2022年2月にWordPressのプラグイン「The Profile Builder」にXSS脆弱性(CVE-2022-0653)が発表されました。

悪用されるとブラウザ上で意図しないスクリプトを実行される可能性があり、アメリカ国立標準技術研究所の脆弱性データベースでは危険度がMediumとなっています。

https://nvd.nist.gov/vuln/detail/CVE-2022-0653

該当プラグインを有効にしている場合、脆弱性を悪用した不正なリンクをクリックすることでブラウザ上で意図しないスクリプトを実行される可能性があります。

対象プラグインとバージョン

「The Profile Builder」はショートコードを使って、フロントエンドのログインフォーム、ユーザー登録フォーム、プロフィール編集フォームを簡単に作成できるプラグインです。

https://ja.wordpress.org/plugins/profile-builder/

今回の脆弱性の影響を受けるバージョンは下記の通りです

・The Profile Builder 5.0.8以下

脆弱性の対策

対策としては、プラグインをアップデートする形になります。WordPressのプラグイン画面から該当プラグインのアップデート有無を確認することをお勧めします。

Webサイトへの影響について

「The Profile Builder」を利用したブログサイトのメールによるユーザー認証のフォールバックページに脆弱性があるため、サイトのユーザーが本脆弱性を悪用したリンクをクリックすることでブラウザ上で不正なスクリプトを実行されてしまう可能性があります。

さいごに

今回ご紹介した脆弱性が影響するプラグインは2022年3月時点で5万件以上のサイトでアクティベートされています。

こうした人気のプラグインでも日々脆弱性が発見され、攻撃に悪用されるリスクがあり、日々のセキュリティアップデートが重要になります。

弊社では日々WordPressおよびプラグインのセキュリティ情報をチェックしており、お客様のサーバーで利用しているプラグインについては検証、本番それぞれの環境でアップデートを代行可能です。

リリース後のWordPressサイトのセキュリティ情報のチェックが追いつかない場合はぜひご相談くださいませ。

コーポレートサイトをクラウドでセキュアに

SiteCloudガイドブック

「SiteCloud」の詳しい内容が分かる資料をご用意しました。
  • コーポレートサイト構築・運用の課題を解決
  • SiteCloudの主な機能
  • 導入事例
  • 導入までの流れ

関連する解決策

最新記事

タグ

詳しい資料をご覧いただけます

    サイバーの鎧のサービス内容を記載した資料をダウンロードできます。
             

【無料診断実施中】サーバーセキュリティ診断

経験豊富なセキュリティ専門技術者が、サーバーの状況を診断して、分かりやすい診断結果と今後の対応策をご覧いただけます。

無料サーバー診断申し込み
close