「TI WooCommerce Wishlist」プラグインに重大な脆弱性。WordPressで稼働しているECサイトへの影響と対策について解説します (CVE-2022-0412)

こんにちは。「SiteCloud」プリセールスの高瀬です。

2022年2月にWordPressのプラグイン「TI WooCommerce Wishlist」にSQL インジェクションの脆弱性(CVE-2022-0412)が発表されました。

悪用されるとデータベースにアクセスされてしまう可能性があり、アメリカ国立標準技術研究所の脆弱性データベースでは危険度がCriticalとなっています。

https://nvd.nist.gov/vuln/detail/CVE-2022-0412

該当プラグインを有効にしている場合、攻撃者が細工したリクエストを送ることでデータベースに任意のクエリを実行してしまう可能性があります。

対象プラグインとバージョン

「TI WooCommerce Wishlist」はWooCommerceのサイトにユーザー同士で共有可能なウィッシュリストを作成できるプラグインです。

https://ja.wordpress.org/plugins/ti-woocommerce-wishlist/

今回の脆弱性の影響を受けるバージョンは下記の通りです

・TI WooCommerce Wishlist 1.40.1未満

脆弱性の対策

対策としては、プラグインをアップデートする形になります。WordPressのプラグイン画面から該当プラグインのアップデート有無を確認することをお勧めします。

Webサイトへの影響について

REST APIでパラメータの処理に脆弱性があるため、「TI WooCommerce Wishlist」を利用しているサイトに対して外部から細工されたリクエストを送ることでデータベースに対して不正なクエリを実行されてしまう可能性があります。

権限なしでデータベースにアクセスされることで、最悪な場合機密情報の流出に繋がってしまう可能性もあるため、プラグインを利用している場合は早急な確認をお勧めします。

さいごに

今回ご紹介した脆弱性が影響するプラグインは2022年3月時点で10万件以上のサイトでアクティベートされています。

こうした人気のプラグインでも日々脆弱性が発見され、攻撃に悪用されるリスクがあり、日々のセキュリティアップデートが重要になります。

弊社では日々WordPressおよびプラグインのセキュリティ情報をチェックしており、お客様のサーバーで利用しているプラグインについては検証、本番それぞれの環境でアップデートを代行可能です。

リリース後のWordPressサイトのセキュリティ情報のチェックが追いつかない場合はぜひご相談くださいませ。

コーポレートサイトをクラウドでセキュアに

SiteCloudガイドブック

「SiteCloud」の詳しい内容が分かる資料をご用意しました。
  • コーポレートサイト構築・運用の課題を解決
  • SiteCloudの主な機能
  • 導入事例
  • 導入までの流れ

関連する解決策

最新記事

タグ

詳しい資料をご覧いただけます

    サイバーの鎧のサービス内容を記載した資料をダウンロードできます。
             

【無料診断実施中】サーバーセキュリティ診断

経験豊富なセキュリティ専門技術者が、サーバーの状況を診断して、分かりやすい診断結果と今後の対応策をご覧いただけます。

無料サーバー診断申し込み
close