イメージギャラリーをWordPressサイトに追加できる「Image Photo Gallery Final Tiles Grid」プラグインにXSS脆弱性。Webサイトへの影響と対策について (CVE-2022-0186)

こんにちは。「SiteCloud」プリセールスの高瀬です。

2022年2月にWordPressのプラグイン「Image Photo Gallery Final Tiles Grid」にXSS脆弱性(CVE-2022-0186)が発表されました。

悪用されるとブラウザ上で意図しないスクリプトを実行される可能性があり、アメリカ国立標準技術研究所の脆弱性データベースでは危険度がMediumとなっています。

https://nvd.nist.gov/vuln/detail/CVE-2022-0186

該当プラグインを有効にしている場合、不正なアップロードデータによってブラウザ上で意図しないスクリプトを実行される可能性があります。

対象プラグインとバージョン

「Image Photo Gallery Final Tiles Grid」はイメージギャラリー、フォトギャラリー、ポートフォリオギャラリー、タイルギャラリー が1つになったプラグインです。

https://ja.wordpress.org/plugins/final-tiles-grid-gallery-lite/

今回の脆弱性の影響を受けるバージョンは下記の通りです

・Image Photo Gallery Final Tiles Grid 3.5.3未満

脆弱性の対策

対策としては、プラグインをアップデートする形になります。WordPressのプラグイン画面から該当プラグインのアップデート有無を確認することをお勧めします。

Webサイトへの影響について

「Image Photo Gallery Final Tiles Grid」を利用しているWordPressサイトで、細工された画像データをアップロードされた場合、ギャラリーのダッシュボード画面閲覧時に意図しないスクリプトがブラウザ上で実行されてしまう可能性があります。

WordPressのセッション情報を盗まれて不正ログインにつながる可能性もあるため、社内のサイト管理者以外のユーザーも画像をアップロードできるようなサイトになっている場合は早めの確認をお勧めします。

さいごに

WordPressを利用している場合はサイトの管理者自身にも攻撃されるリスクがあり、各種プラグインのセキュリティ対策も重要になります。

弊社では日々WordPressおよびプラグインのセキュリティ情報をチェックしており、お客様のサーバーで利用しているプラグインについては検証、本番それぞれの環境でアップデートを代行可能です。

リリース後のWordPressサイトのセキュリティ情報のチェックが追いつかない場合はぜひご相談くださいませ。

コーポレートサイトをクラウドでセキュアに

SiteCloudガイドブック

「SiteCloud」の詳しい内容が分かる資料をご用意しました。
  • コーポレートサイト構築・運用の課題を解決
  • SiteCloudの主な機能
  • 導入事例
  • 導入までの流れ

関連する解決策

最新記事

タグ

詳しい資料をご覧いただけます

SiteCloudのサービス内容を記載した資料をダウンロードできます。
SiteCloudの機能や事例が分かる
無料資料ダウンロード
             

【無料診断実施中】サーバーセキュリティ診断

経験豊富なセキュリティ専門技術者が、サーバーの状況を診断して、分かりやすい診断結果と今後の対応策をご覧いただけます。

無料サーバー診断申し込み
close