WordPressの広告プラグイン「Ad Inserter」にXSS脆弱性。Webサイトへの影響と対策を解説します (CVE-2022-0288)

こんにちは。「SiteCloud」プリセールスの高瀬です。

2022年2月にWordPressのプラグイン「Ad Inserter」に XSS脆弱性(CVE-2022-0288)が発表されました。

悪用されるとブラウザ上で意図しないスクリプトを実行される可能性があり、アメリカ国立標準技術研究所の脆弱性データベースでは危険度がMediumとなっています。

https://nvd.nist.gov/vuln/detail/CVE-2022-0288

該当プラグインを有効にしている場合、不正な入力によってブラウザ上で意図しないスクリプトを実行される可能性があります。

対象プラグインとバージョン

「Ad Inserter」は高度な広告機能を多数搭載した広告管理プラグインです。

今回の脆弱性の影響を受けるバージョンは下記の通りです

・Ad Inserter 2.7.10未満

脆弱性の対策

対策としては、プラグインをアップデートする形になります。WordPressのプラグイン画面から該当プラグインのアップデート有無を確認することをお勧めします。

Webサイトへの影響について

WordPressでプラグイン「Ad Inserter」を利用している場合、プラグインの設定変更時に本脆弱性の影響を受ける可能性があります。

広告情報のHTML部分に細工された内容が入力されることでページ内で広告を表示した際にブラウザ上で意図しないスクリプトが実行される可能性があります。

管理者が入力する情報に依存するため本脆弱性単発で影響する可能性は低いですが、ユーザーに影響する可能性があるため可能なタイミングでアップデートをお勧めします。

さいごに

プラグインページを見る限り、2022年5月時点で「Ad Inserter」プラグインを有効化しているサイトは20万件を超えています。

こうした人気のプラグインでも日々脆弱性が発見され、攻撃に悪用されるリスクがあるため、日々のセキュリティアップデートが重要になります。

弊社では日々WordPressおよびプラグインのセキュリティ情報をチェックしており、お客様のサーバーで利用しているプラグインについては検証、本番それぞれの環境でアップデートを代行可能です。

リリース後のWordPressサイトのセキュリティ情報のチェックが追いつかない場合はぜひご相談くださいませ。

コーポレートサイトをクラウドでセキュアに

SiteCloudガイドブック

「SiteCloud」の詳しい内容が分かる資料をご用意しました。
  • コーポレートサイト構築・運用の課題を解決
  • SiteCloudの主な機能
  • 導入事例
  • 導入までの流れ

関連する解決策

最新記事

タグ

詳しい資料をご覧いただけます

SiteCloudのサービス内容を記載した資料をダウンロードできます。
SiteCloudの機能や事例が分かる
無料資料ダウンロード
             

【無料診断実施中】サーバーセキュリティ診断

経験豊富なセキュリティ専門技術者が、サーバーの状況を診断して、分かりやすい診断結果と今後の対応策をご覧いただけます。

無料サーバー診断申し込み
close