WordPressのセキュリティプラグイン「SiteGround Security」に複数の脆弱性。Webサイトへの影響と対策を解説します (CVE-2022-0992、CVE-2022-0993)

こんにちは。「SiteCloud」プリセールスの高瀬です。

2022年4月にWordPressのプラグイン「SiteGround Security」に複数の脆弱性(CVE-2022-0992、CVE-2022-0993)が発表されました。

悪用されるとWordPressのログイン認証を突破されてしまう可能性があり、アメリカ国立標準技術研究所の脆弱性データベースでは危険度がCriticalとなっています。

https://nvd.nist.gov/vuln/detail/CVE-2022-0992

https://nvd.nist.gov/vuln/detail/CVE-2022-0993

該当プラグインを使用しているサイトについて、特定の条件でログイン認証を突破されてしまう可能性があります。

対象プラグインとバージョン

「SiteGround Security」はWordPressに2要素認証などの機能を実装できるセキュリティ強化プラグインです。

今回の脆弱性の影響を受けるバージョンは下記の通りです

・SiteGround Security プラグイン 1.2.5 以下

脆弱性の対策

対策としては、プラグインをアップデートする形になります。WordPressのプラグイン画面から該当プラグインのアップデート有無を確認することをお勧めします。

Webサイトへの影響について

2要素認証設定時の認証欠落(CVE-2022-0992)

2要素認証の初期設定時にパスワードによる本人確認が行われないため、認証されていないユーザーが管理者としてログインできてしまう可能性があります。

バックアップコード使用時の認証欠落(CVE-2022-0993)

2要素認証におけるバックアップコード使用時にパスワードによる本人確認が行われないため、認証されていないユーザーが管理者としてログインできてしまう可能性があります。

いずれの場合も本人認証を突破されるとサイトを乗っ取られてしまう可能性もあるため、早めの対応が必要になります。

さいごに

WordPressのセキュリティを強化するプラグインはいくつか存在しますが、導入すれば安全、ということではなく、導入後に適切に設定、運用を行う必要があります。プラグインそのもののセキュリティアップデートの確認、実施も重要な運用項目です。

弊社では日々WordPressおよびプラグインのセキュリティ情報をチェックしており、お客様のサーバーで利用しているプラグインについては検証、本番それぞれの環境でアップデートを代行可能です。

リリース後のWordPressサイトのセキュリティ情報のチェックが追いつかない場合はぜひご相談くださいませ。

コーポレートサイトをクラウドでセキュアに

SiteCloudガイドブック

「SiteCloud」の詳しい内容が分かる資料をご用意しました。
  • コーポレートサイト構築・運用の課題を解決
  • SiteCloudの主な機能
  • 導入事例
  • 導入までの流れ

関連する解決策

最新記事

タグ

詳しい資料をご覧いただけます

    サイバーの鎧のサービス内容を記載した資料をダウンロードできます。
             

【無料診断実施中】サーバーセキュリティ診断

経験豊富なセキュリティ専門技術者が、サーバーの状況を診断して、分かりやすい診断結果と今後の対応策をご覧いただけます。

無料サーバー診断申し込み
close