Drupal「Entity Reference Tree Widget」モジュールにXSS脆弱性。Webサイトへの影響と対策 (SA-CONTRIB-2022-026)

こんにちは。「SiteCloud」プリセールスの高瀬です。

2022年2月にDrupalの「Entity Reference Tree Widget」モジュールにXSS(クロスサイトスクリプティング) 脆弱性(SA-CONTRIB-2022-026)が発表されました。

Drupalのアドバイザリページでは危険度が中程度のModerately Criticalとなっています。

https://www.drupal.org/SA-CONTRIB-2022-026

脆弱性の対象となるモジュールとバージョン

「Entity Reference Tree Widget」はDrupalのエンティティをツリー構造で表示するウィジェットです。影響を受けるバージョンは以下の通りです。

・Entity Reference Tree Widget 2.0.2未満

脆弱性の対策

既に修正済みバージョンが提供されているため、Drupalの管理画面から「Entity Reference Tree Widget」モジュールをバージョンアップする形になります。

https://www.drupal.org/project/entity_reference_tree

Webサイトへの影響について

Drupalのエンティティ情報に不正な値を入れることで表示したブラウザ上で意図しないスクリプトを実行される可能性があります。

エンティティ情報を編集する権限があるサイト管理者の操作によるもののため、外部からサイトに攻撃される可能性はほとんどありません。
ただし、サイト管理者がDrupalにログインしている状態で本脆弱性を悪用したリンクをクリックすることで、ブラウザ上で不正なスクリプトが実行される可能性がありますので、サイト管理をしている環境では不用意に外部サイトにアクセスしないようにすることをお勧めします。

さいごに

DrupalはオープンソースCMSの中でも高機能と言われており、さまざまなモジュールが用意されています。

CMSのカスタマイズ性が高い一方で、各機能のセキュリティ対策には注意が必要です。

弊社ではお客様サーバーのご利用状況に応じて、エンジニアが日々発表される脆弱性の影響有無を確認して、必要に応じて修正パッケージの適用を行なっております。

サイト制作、運用が多忙でサーバーソフトの脆弱性対策を行うことが難しい場合はぜひご相談くださいませ。

コーポレートサイトをクラウドでセキュアに

SiteCloudガイドブック

「SiteCloud」の詳しい内容が分かる資料をご用意しました。
  • コーポレートサイト構築・運用の課題を解決
  • SiteCloudの主な機能
  • 導入事例
  • 導入までの流れ

関連する解決策

最新記事

タグ

詳しい資料をご覧いただけます

    サイバーの鎧のサービス内容を記載した資料をダウンロードできます。
             

【無料診断実施中】サーバーセキュリティ診断

経験豊富なセキュリティ専門技術者が、サーバーの状況を診断して、分かりやすい診断結果と今後の対応策をご覧いただけます。

無料サーバー診断申し込み
close